shadowsocks – libev 服务端的部署

在VPS上部署shadowsocks,推荐使用C语言编写的基于libev的shadowsocks-libev的服务端。下面介绍在Linux系统的VPS上安装并配置的方法。Linux请采用近期的发行版,不要过老。本文基本是照着github上的readme翻译的,给那些英文苦手一点帮助。本篇只提供部分安装方法,其他方式请参考github上原repo的readme。

由于shadowsocks-libev变动频繁,请以shadowsocks-libev的Github页面的readme为准,如有问题可至issue页面查找有无类似问题,或者发issue提问:

https://github.com/shadowsocks/shadowsocks-libev

如果您还未购买将要购买国外VPS搭建shadowsocks,这里为您推荐几家VPS提供商,详情见《关于本站》页面。

一、安装shadowsocks服务端

方法1. APT从repo安装。

Ubuntu 14.04/16.04 版本需要先添加作者的PPA:

Ubuntu 16.10及以上版本则可以直接从Ubuntu的官方repo安装,无需上述步骤。

接下来更新软件列表并安装即可。

方法2. 使用脚本自动编译deb安装,适用于Debian (>=8) / Ubuntu 14.04 (Trusty) / 16.04 (Xenial) / 16.10 / Higher

(会自动编译安装所有依赖包,并同时安装simpleobfs plugin)

方法3. 手动编译安装(Ubuntu 16.04 / Debian 8及以上),在你需要从最新master源码编译时候可以使用这种方式。

先通过git下载源码:

安装必须的包:

Debian 8的用户,注意需要从Debian Backports安装libsodium(最低版本v1.0.8)。

注意:新版本需要debhelper版本大于等于10,不满足的请使用Backports安装新版debhelper:

然后生成deb包并安装,一步步执行(留意是否出错 如果出错需要检查系统或者之前的步骤):


其他Unix-like的系统,特别是Debian-based的Linux发行版如: Ubuntu, Debian or Linux Mint

先从最近的源码编译安装libmbedtls和libsodium

安装依赖包:

编译:

二、配置与启动

1、配置文件为:/etc/shadowsocks-libev/config.json,格式说明:

其中:

server:主机域名或者IP地址,尽量填IP

server_port:服务器监听端口

password:密码

method:加密方式 所有支持的加密方式请参照官方文档。这里本人推荐只使用支持AEAD的加密方式,包括以下五种: aes-128-gcm/aes-192-gcm/aes-256-gcm/chacha20-ietf-poly1305/xchacha20-ietf-poly1305

timeout:连接超时时间,单位秒。要适中。

注意引号。

2、控制启动、停止、重启:

由于目前大部分新的linux发行版都已经支持systemd,因此,可以统一使用如下命令

 

需要前台运行时候,执行ss-server命令运行,具体用法如下:

一个例子如:

查看shadowsocks是否正确启动并监听相应端口,看到有ss-server进程LISTEN正确的端口就表示成功:

服务器优化

1.  开启TCP Fast Open:

需求: 系统内核版本≥3.7,shadowsocks-libev≥3.0.4。

修改 /etc/sysctl.conf ,加入如下一行:

执行如下命令使之生效:

配置文件 /etc/shadowsocks.json 增加一行:

2. 其他优化以及配置单边/双边加速

参照官方说明: http://shadowsocks.org/en/config/advanced.html

不过官方说明里面的TCP流控使用了hybla:

这里推荐使用bbr而不是hybla。bbr需要内核版本不小于4.9,如果内核版本不够,需要更换内核。注意换内核操作不当可能导致vps无法开机,如果发生问题,有救援模式的可能还能救一下,否则只能找客服处理;KVM的通常更换内核没有问题,OpenVZ是不支持更换内核的。具体的更换内核和开启bbr的步骤参考这里:

开启TCP BBR拥塞控制算法

再推荐一个一键脚本:

Debian/Ubuntu 开启 TCP BBR 拥塞算法

然后换完内核开启BBR之后,可以再换一个魔改版的BBR,优化了参数:

Debian/Ubuntu TCP BBR 改进版/增强版

注意,OpenVZ的VPS可能无法修改大部分的属性,因此如果想要优化网速需要考虑:

1. 使用kcptun双边加速;

2. 通过linux kernel library来实现,同样是一键脚本:

OpenVZ 平台 Google BBR 一键安装脚本

如果您还未购买将要购买国外VPS搭建shadowsocks,这里为您推荐几家VPS提供商,详情见《关于本站》页面。

66 条评论

  1. 头像nobody 回复

    很好,我是用第一种方法安装的。

  2. 头像vl 回复

    请问在/etc/apt/sources.list末尾添加:
    deb http://shadowsocks.org/debian squeeze main

    这条命令该怎么输呢?我太小白,不能看懂。可以告诉一下吗?

  3. 头像bismall 回复

    我发现有一处错误…
    ./configure && make
    make install
    应为
    ./configure && make && make install

    1. cokebarcokebar 文章作者 回复

      额 你只是把两步和到一起,请问有啥区别?

    2. cokebarcokebar 文章作者 回复

      如果你说的是&&变成了&&,属排版问题,已经改好了

  4. 头像blackhorse 回复

    谢谢,在AWS EC2上安装好了,但是还是很难搞定AWS的端口问题……

  5. 头像韩少西 回复

    root@li739-83:~# cd shadowsocks-libev
    root@li739-83:~/shadowsocks-libev# dpkg-buildpackage -us -uc
    dpkg-buildpackage: source package shadowsocks-libev
    dpkg-buildpackage: source version 1.6.1-1
    dpkg-buildpackage: source changed by Max Lv
    dpkg-buildpackage: host architecture amd64
    dpkg-source –before-build shadowsocks-libev
    dpkg-checkbuilddeps: Unmet build dependencies: debhelper (>= 7.0.50~) gawk
    dpkg-buildpackage: warning: build dependencies/conflicts unsatisfied; aborting
    dpkg-buildpackage: warning: (Use -d flag to override.)
    root@li739-83:~/shadowsocks-libev# cd ..
    root@li739-83:~# dpkg -i shadowsocks-libev*.deb
    dpkg: error processing shadowsocks-libev*.deb (–install):
    cannot access archive: No such file or directory
    Errors were encountered while processing:
    shadowsocks-libev*.deb
    出错啦,求帮助

    1. cokebarcokebar 文章作者 回复

      安装或者更新一下debhelper

      1. 头像韩少西 回复

        好了,谢谢啦,这个可以自己启动吧,如果我重启了VPS的话。

        1. cokebarcokebar 文章作者

          是的 编译成deb包的话,安装时候就会自动设置开机自启了

  6. 头像heq 回复

    如果在老的系统上编译(比如i686),需要另外安装
    # apt-get install gcc-multilib

    否则会在config.log里报错
    fatal error: sys/cdefs.h: No such file or directory

    1. cokebarcokebar 文章作者 回复

      感谢提出。我这篇基本只是照着github翻译的所以也没考虑这么多

  7. 头像呆三 回复

    python版本不是更方便么?

    1. cokebarcokebar 文章作者 回复

      libev性能最佳

  8. 头像keboge 回复

    作者你好,又来打扰。
    搬瓦工主机,系统是Debian 6,按照编译的方法安装了shadowsocks-libv,显示安装成功,但是没有发现“/etc/shadowsocks-libev/config.json”这个配置文件,根目录下没有“etc”文件夹,请问我是自己新建相关文件夹和config.json文件就行了吗?
    另外如果是合用VPS的情况,如何建立分别的账户?

    1. cokebarcokebar 文章作者 回复

      这是更新后的步骤,之前没有这一步,感谢提醒,我更新上去了

      1. 头像Zhiyu 回复

        🙂

  9. 头像chen 回复

    第一步就报错
    pgp: no valid openPGP data found
    求解

发表评论

电子邮件地址不会被公开。 必填项已用*标注

请输入验证码 * 请输入正确的验证码