KMS 自动激活利器 – vlmcsd for OpenWrt / LEDE

KMS 激活是很多人激活 Windows / Office 软件的常用方法,非常好用。然而大多数都需要在本机上运行激活软件,并且如果想要自动180天续期则需要安装加载项,而且每台设备都要做一次。

如果在局域网中有一台常开的设备,在这台设备上运行KMS服务器软件,那么连入该局域网的所有设备就可以自动KMS激活而无需使用那些KMS激活软件了,可以说是一劳永逸。常开的设备?又不想太浪费电?当然路由器是最佳选择。路由上当然也是有这样的软件的。


vlmcsd 是HotBird64所写的一款C语言编写的KMS模拟器。http://forums.mydigitallife.info/threads/50234

软件本身同时兼容Linux和Windows;同时由于是C语言所写,软件体积也很小,部署到路由器上最合适不过了。本人这里提供一个 OpenWrt / LEDE 的移植版本,提供部分常见平台的ipk预编译包,可以直接下载安装。你也可以自行下载源码编译安装。
下载完成后,上传至路由/tmp目录,安装:
打开LuCI,“服务”→“vlmcsd”:

直接勾选启用、自动激活;配置文件保留默认即可。点击保存&应用。

 

接下来测试一下自动激活是否配置成功,在PC端(Windows)的命令行执行:

如果有返回的SRV记录,并且IP为路由器IP则成功。

接下来你就可以装个 Windows / Office VL版试试啦。

各版本序列号可以在这里找:

https://github.com/Wind4/vlmcsd/tree/gh-pages

32 条评论

  1. 头像JoeyWei 回复

    羽大,ipk现在怎么都不能下了,我上个月(11月份)还下!可以打包一份发给我吗!所有的

    1. cokebarcokebar 文章作者 回复

      昨天更新版本,弄到半片没弄完,现在可以了。现在是1112版本,并且用的OpenWrt 18.06的SDK编译的,17.01下没测试,应该是可以用,15.05肯定是用不了了。

  2. 头像Joey Wei 回复

    luci 在18.06.2安装不了了

  3. 头像Joey Wei 回复

    不好意思,命令打错了!

  4. 头像macker 回复

    office2019要添加什么配置文件内容呢?目前window10可以自动激活。vlmcsd 用的是svn1112-1版本,默认配置。

    1. cokebarcokebar 文章作者 回复

      按理说1112版本应该支持office2019了

  5. 头像電腦達人 回复

    你好不好意思想問一下
    因為之前裝過很多次都可以用
    但這次很奇怪
    opkg install vlmcsd_svn1112-1_x86_64.ipk
    opkg install luci-app-vlmcsd_1.0.2-1_all.ipk
    下指令過了很久都沒有出現任何訊息
    但是設備有沒有死掉的狀態
    但就是opkg被lock住要刪掉.lock的檔案
    可是就無法把這兩個檔案裝好來
    之前我是用server2016的hyper-v裝openwrt然後再裝這兩個套件
    都沒問題正常使用都可以驗證
    但換到了ESXI上去後就有狀況
    大大是不是有動到什麼嗎?
    我的openwrt的版本:OpenWrt 18.06.2 r7676-cddd7b4c77 / LuCI openwrt-18.06 branch (git-19.020.41695-6f6641d)

  6. 头像電腦達人 回复

    我後來發現是因為curl -O 跟wget的問題
    就是在下載檔案的時候出問題了這樣子
    拍謝我自己沒弄好

  7. 头像lolicon 回复

    * satisfy_dependencies_for: Cannot satisfy the following dependencies for luci-app-vlmcsd:
    * vlmcsd *
    * opkg_install_cmd: Cannot install package luci-app-vlmcsd.

    LEDE Reboot 17.01.6 r3979-2252731af4 / LuCI lede-17.01 branch (git-18.201.27126-7bf0367)
    这个版本安装不了

    1. 头像lolicon 回复

      没问题了,我忘记安装上一个文件

  8. 头像Burning_C4 回复

    建议调整配置文件框的大小 config.size = 100 config.rows = 25

    1. cokebarcokebar 文章作者 回复

      感谢建议,回头我改一下

  9. 头像sk 回复

    目前用这个版本装不了
    Powered by LuCI openwrt-18.06 branch (git-19.170.32094-4d6d8bc) / OpenWrt 18.06.4 r7808-ef686b7292
    之前这个没问题
    Powered by LuCI lede-17.01 branch (git-18.201.27126-7bf0367) / LEDE Reboot 17.01.6 r3979-2252731af4

    请问羽大有没有合适的可以用?

  10. 头像sk 回复

    不好意思,是我安装次序问题,先装了luci,现在没问题了

发表评论

电子邮件地址不会被公开。 必填项已用*标注

请输入验证码 * 请输入正确的验证码